Vice setup


#1

Hi. Have anyone managed to start a game using the Vice core on RC4? Can’t get it to work. Any tricks there?


#2

had no luck on that. have tried different games (taken from goodgb64 3.00 set)

if i try to start a game (Turrican 1/2, Creatures, IK+ …) the “C64 Screen” says:

LOAD"*".8,1: SEARCHING FOR * ?DEVICE NOT PRESENT! ERROR

has copied the data-folder from here: https://github.com/libretro/vice-libretro/tree/master/vice/data to “system” folder (using lakka)


#3

Turn on True drive emulation in the quick menu options and change the drive device to 1541.

Takes 5 to 10 mins to load a .d64 image (!)

Out of interest, doesn’t Vice have a ‘warp’ option to speed the loading?


#4

… after 5 to 10 mins of loading …

:smiley:

Setting to 1541 drive and enable TrueDrive was the Solutions for my issue. :relieved:

Thank you very much. now i will buy a usb adapter for my good old competion pro joysticks and “test” a bit :stuck_out_tongue:


#5

Great stuff!

So far, I’ve enjoyed ‘Impossible Mission’ and have ‘Uridium’ waiting.

Any C64 classics that anyone can recommend?


#6

The C64 have a really nice libary of: arcade-ports & puzzle games (Puzzle Bobble, Mario Bros, Donkey Kong, Rampage), Simulations (has some of the nicest “manager-games” ever made) adventures (Zak, Maniac Manson, Elvira 1+2, Waxworks), Strategy (Rings of Medusa, Pirates) and some really-really cool platformer/action classics (like Giana Sisters, Rick Dangerous, Turrican 1+2, Hawkeye, Last Ninja 1-3) and great Shoot em Ups (Uridium, X-Out, Armalyte, Kartakis) also few fighting games are really nice (IK+, Babarian, Target Renegade) that are only very few titles. if you dig a bit you will find a lot more !!!

my absolute favorite (C64-exclusive) Game is : "Creatures II - Torture Trouble" think this is not so a real classic… (maybe more hidden gem in any way) but still worth to be played here is a longplay of it: https://www.youtube.com/watch?v=6bIpXvt0wxo&t=969s if you want to try it, you have to change/swap the disc to disc2 during the “Cracktro”.


#7

Use and hold fastforward key during loading to speed up load !

Retroarch by design cap the framerate to audio sync (50fps in this case) . On my pc it allow to jumps to emulation speed to 500% then loading time reduce by x5, then when disk is loading (when you see decompress routine most of time ) release fastforward key.

Btw you can also setup a ide64 hdd emulation (then load from virtual hdd or from usb server ) tricky but great http://www.ide64.org/vice_ide64_howto_rev2.txt


#8

I just tried Arkanoid and its working up to a point. It passes the cracktro and makes it to the instructions where you have to press runstop to continue which is escape key. Pressing escape key quits retroarch so I guess I need to configure input settings in retroarch ?


#9

There is a virtual keyboard when using a joystick. But it is not working well. I’m using a PS3 controller, pressing the square pops it up. Before that you have to press Select to enable joystick (Why? Don’t know, just told Retroarch in the quick settings that I use a joystick).

The problem with the virtual keyboard is that it is slightly to big for the screen. You can’t just reach the last line of the keyboard where all the good stuff is (F1, Space etc.). Having this fixed maybe solves a lot of problems.

Sometimes I think emulating computers in such an environment isn’t the best idea at all…! Sticking with consoles causes much less problems.


#10

best is to enable an hotkeys to not exit RA pressing escape. or there is another option to inhibit the RA keys shortcuts.


#11

you have to enable joystick because i don’t want joystick keys/shortcuts (that are mapped to keyboard by default if no joy controller ) interact with my keyboard command!

For the size , i can reach by using the scrollbar :slight_smile: , or using a true mouse … but maybe too big i admit.


#12

Scrollbar doesn’t work here while using a joystick (PS3 Controller). In the '“main” menu the scrollbar just works fine!


#13

strange it works for me with my ps3 controller :slight_smile:


#14

I’m on RPi3. Maybe that is a reason?!


#15

I have a pi3 , i will check asap . BTW on Pi3 be sure to use fastsid (in gui instead of resid) to have fullspeed.


#16

Thanks guys I think I will try the ide64 method later.


#17

Really good work R-Type!!! nice to see some “bread bin” classics in a modern lakka envoiroment :slight_smile:
The Core is looking very usable but a little bit “uncomfortable” in cases. have a few questions/requests about it.

want to use a actuall keyboard for the C64 Keyboard things with additional joysticks/joypads (much like the original hardware), can i use the game-focus for this and if yes: can i deactivate/unmap the buttons for VICE OSD-Keykoard/OSD-Settings from keyboard or set it to keys the C64 not uses (now its “a” also in game focus mode)? can maybe better with on/off switch for OSB-Keyboard in Quickmenu instead of a hotkey?

few another things that i notices: if i set the drivetype to 1541 in RA quickmenu the Vice GUI shows allways 1542 instead ? is it a bug or doesn’t it matters at all? Why the C64 Screen is showing: “?DEVICE NOT PRESENT! ERROR” when truDrive is disabled all the time. With Standalone Vice i can start most games by leave this setting activated (will decreases loadtimes dramatically).

and how can i swap/change disc-images? After i insert a new image in DF8… the “C64” make a reset-makes impossible playing “multi-side” games, what do i wrong ?


#18

Thank you very much for adding Vice to Lakka!

Of course I am very happy for this :slight_smile:


#19

Forget about this. I just tried to press the arrow in the right corner. Doesn’t work. But grabbing the whole scrollbar holding down the fire button make it move.

But making the virtual keyboard fit to one screen would be a nice thing to add in the future.


#20

With my latest efforts I tried it on my android box s905 with libreelec and works very well. I used jokerzbox retroarch addon for kodi and copied the vice core over from lakka. Made a few settings adjustments to the display in RA changing display to 16/9 intead of core provided. F10 brings up the gui and F9 the virtual keyboard. In kodi display setting I changed display to 50hz and vice runs very smooth for pal games.