Why do shaders look all jagged for me?

How come Scalefx 9x (according to Filthy Pants’ blog) is supposed to look like this

but looks like this for me ?

1 Like

looks to me you’re using the bsnes-accuracy core which doubles the horizontal resolution. this messes up the edge detection of various filters. a quick fix would be to switch the core.


You are correct. Why does bsnes do this with snes titles that aren’t even running in hi-res mode?

The accuracy core does it with all games no matter what, while the balanced core only does it for cores that use the high-res mode. I forget byuu’s reasoning for it, but I think it has to do with not being able to change the resolution mid-scanline otherwise or something like that.

If you still want to use bsnes-accuracy, you can add a first shader pass that forces an absolute scale_x0 of 256 pixels. This will make high-res text and effects look weird/bad, but shaders should work as expected.

1 Like

this happens with me with mednafen beetle psx and with epsxe (xbrz)!!! Happens when internal rez is above x1. it never use to happen before! For FF6 for instance, it looks proper when loading the save file and you look at the menu screen. But when you go into game and look at the same menu screen, it’s all pixelated.

What would be the deal with those? Is it a cache thing?

For beetle-psx with increased res, it’s because the shader can’t tell what’s supposed to be filtered. That is, once you go beyond 1x, it thinks the jaggies are intentional. You can, however, use the super-xbr-*-3d shaders, which will discriminate between 2D and 3D content and only upscale the 2D stuff.


so why is it that this didn’t happen before (months ago when we were testing the different versions with that shader)? And why does it do it right when you’re loading the menu pic (memcard) but not when directly in game?

Is there a way in the shader to make it accomodate the higher rezzes now?

Dunno. If the behavior has changed, pinpoint where it happened I can try to figure out what’s going on.

memory card screen: in game screen:

it never use to be like this. the only thing different that happened to my pc since Jan is a slew of windows updates i installed recently. The pics are epsxe. But everything is pixelated in retroarch with the scalefx shaders now when rez is increased. I tried turning off cache in the ncp but no dice.

Is scalefx scalable like guests scanline shaders? maybe that would help? I dunno.

1 Like

no, the way the pattern-identifying shaders works breaks at increased internal resolution unless they’re written around dealing with it.

1 Like

Hello, Sorry to bump an old '17 thread but I encounter exactly the same problème than @andawra except i have it also with scalefx9x, scalefx-hybrid, scalefx-raa and several other (scalefx-aa-fast, scalefx-raa-aa, …) And maybe with any scale shader. For snes i uses snes9x but also have the same problem on nes and master system (not tried other system yet).

I thing that the problen came from my retroarch output settings but I was unable to find the problème. Tried 720p and 1080p output, several ratio (16/9, 4/3 …), With or without pixel perfect, with or without crop.

Does anybody have an idea ? Thanks.

Do you have any video filters enabled in settings > video (down at the bottom)?

No, I have filtering enabled but same without it. As an exemple here is what scalefx-aa-fast look like with ratio set to “core provided”. scale9x is even worse.

it sure looks like you’re pre-scaling it somewhere to me.

ok, I was thinking the same but was unable to find the option so if you think that too i’m on the good way. I think i’ll have to dig into retroarch and emulationstation config files. Just to be sure what do you advise me to force on retroarch before playing with other options ? Do I need to fix ratio to core-provided or any fixed values ? Pixel perfect yes/no ? Overscan yes/no ?


None of that should have any effect. The only things I know to look at are to ensure you don’t have any video filters active in settings > video and make sure there’s no shader passes setting a scale before the ones that should be happening (this shouldn’t be the case if you just ‘load preset’ and go right to it).

:thinking: didn’t set any and tried to use “start” to reset filters (according retroarch FAQ) juste in case but no change. Maybe i’ll try a clean install or to change sytem (using recallbox right now maybe try lakka or retropie). Also played with shader settings and moving scale factor from 3x to 2x gave me a nicer image. Seem to confirm something else also does a scaling).

Some update : So i ended trying several emulation systems. With the same rom+core+shader+ratio i have the same problem on recalbox and batocera and retropie.

BUT everything is fine using lakka. The shaders gave me the expected render on that system :heart_eyes:.

As both use retroarch now i have to figure the differences in retroarch settings (or stay with lakka but not my favorite)

1 Like

Maybe you have chosen a video filter in settings/video/video filter. If so you just delete it in the config file. Sounds to me that is the case.

No it does the same with fresh install (flash card, copy rom, lauchn and select shader).

I also tried to export retroarch.cfg from lakka to check differences and use it wholes “video_xxx” settings into other systems but still have the same problem :sob: Tried also on 3 different screen.

What is strange is that i have the problem on the 3 different systems that use emulationstation+retroarch ( recalbox/batocera/retropie) but not on lakka which only use retroarch. Maybe emulationstation had something to do in my problem.