Any way at all to dual-boot on a laptop?

hi guys, i have been trying to dualboot lakka and i know it isn’t supported but is there ANY WAY at all? currently i have win7 and linuxmint dualbooted but i can change that if its needed. i really want lakka dual-booted so help would be greatly appreciated.

If you already have Mint installed, you could just install RetroArch there. Lakka is just a pared-down linux that boots directly into RA.

that is probably what i’ll do, but i was still wondering if theres any way to make lakka think its not in dualboot, i like doing stuff like this and it’d be a cool thing to show my friends

would you consider booting off usb for lakka? that’s what I do…saves n everything still works

Booting on USB will even let you access the roms on your laptop hard drive.

PXE booting is also working. (been booting OpenElec of PXE for years now…)

did it :smiley: first create two partitions and label them system and storage. system should be pretty small like no larger than 2gb but storage should be as much as you need(you are going to put your roms on that partition)

then go to your other linux distro and run gparted. Find your system partition and right click it, click manage flags and check boot

then load lakka to a usb and then copy KERNEL and SYSTEM to your linux home directory or some other directory

then mount system partiton that you created before and use terminal to copy the files from your home directory to you partition so like this: sudo cp /path/to/SYSTEM /run/media/user/system and for kernel sudo cp /path/to/KERNEL /run/media/user/system (im on arch so for me its /run/media/user/system but may be different for your distro)

now the system is installed…you just need to add it to grub. to do this open 40_custom in grub.d so sudo gedit /etc/grub.d/40_custom or sudo nano /etc/grub.d/40_custom and add this inside.

menuentry “lakka” { search --set=root --label system --hint hdX,msdosY linux /KERNEL boot=LABEL=SYSTEM disk=LABEL=storage quiet } after you have done that run sudo update-grub or in my case grub-mkconfig -o /boot/grub/grub.cfg if you want to add roms download some roms to your linux mint distro mount storage partition and put your roms into roms folder :smiley: DONE! reboot and enjoy your new lakka system :smiley:

Sure it works :slight_smile:

yeah it does :smiley: tried it :smiley: based on openelec dual boot guide :smiley:

Lakka (openELEC) supports a handful of kernel boot parameters. If you wish to retain ssh access to your Lakka device, you will need to include “ssh” in the kernel command line.

After successfully getting a dual-boot system installed, I searched quite a bit before learning why I kept getting “connection refused” when trying to ssh into my device.

what about dool boot windows/ and lakka?

(Sorry if this is exactly what you guys are talkign about here.)

From reading this thread it sounds more like instructions are linux based. Which i am not tooo familiar with.

HI all grate post but I’m abit stuck iv followed your steps for the manual install of lakka but when it comes to boot I get a error msg hoping for a little help on what’s going on thanks all

dual boot lakka is like dual boot OpenELEC, I got a quad boot setup with windows, manjaro Linux, LibreELEC and Lakka, just used a program call Grub Customizer and also used the guide on OpenELEC wika on how to dual boot, can boot into any OS with out any problems.

Ok thanks I’ll have a look later

1 Like

@Jmh474: could you solve this problem?

Unfortunately, I have the same error while booting

I tried a bunch of things. I would be glad about some help. I test the setup in a VMware workstation. I have an efi bios setup with gpt partiton table.

Partition Info _Efi System partition | mount=/boot/efi = sda1 grub partition | mount=/boot = sda2 ubuntu | mount=/ = sda3 LibreELEC | System = sda4 LibreELEC | Data = sda5

grub config: menuentry “LibreELEC” { set root=(hd0,gpt4) linux /KERNEL boot=/dev/sda4 disk=/dev/sda5 quiet } menuentry “LibreELEC debugging” { set root=(hd0,gpt4) linux /KERNEL boot=/dev/sda4 disk=/dev/sda5 debugging }

Error *** Error in mount_flash: mount_common: could not mount /dev/sda4 ***

HI fandaro I have sort of got it working by following badcase set up, follow his setup guide Lakka triple booting, but if you read my comment you’ll see why I said sort of but it works grate.


LABEL 1 KERNEL /lakka2 APPEND boot=UUID=c2eb82a8-2d8c-4f34-af8d-24294b9d9a4d disk=UUID=6bb922e2-3ee6-4bb2-9b4d-777af9613d2e quiet ssh vga=current vt.global_cursor_default=0 loglevel=2

LABEL 2 KERNEL /lakka2 APPEND boot=UUID=c2eb82a8-2d8c-4f34-af8d-24294b9d9a4d installer quiet tty vga=current vt.global_cursor_default=0 loglevel=2

LABEL 3 KERNEL /libreelec8 APPEND boot=UUID=8b999601-2593-4db7-b1fc-9affcd26514e disk=UUID=90b8f94d-b4fb-4b07-8a8f-2830c5a32d28 portable quiet

LABEL 4 KERNEL /libreelec8 APPEND boot=UUID=8b999601-2593-4db7-b1fc-9affcd26514e installer quiet tty vga=current

LABEL 5 KERNEL /linux APPEND root=/dev/ram0 rw vga=normal initrd=riplinux.gz

LABEL 6 KERNEL /linux APPEND xlogin keymap=us xkeymap=us root=/dev/ram0 rw vga=normal initrd=riplinux.gz

my usb flash drive has 4 partitions, i’ve had to modify it on gparted and copy the new UUIDs