Hi, I have a question about shaders

Hello everyone, this is my first post.

First of all, I apologize for my level of English, I’m going to use Google translate.

I love RetroArch but I have a problem and I would like to know if you can help me. I have a computer made up of an Core i7 13700KF processor and an RTX 4070ti graphics card. When I start to emulate Sega Genesis, Super Nintendo, TurboGrafx, Arcade, etc., everything works perfectly. Smooth as silk.

But to which I apply some shader or overlay (it doesn’t matter which one, it can be crt-pi or Mega Bezel) the games slow down, but it is not something constant happened in certain places.

An example: In Earthworm Jim on the Sega Genesis, early on when you throw the cow and bounce off the tires, jumping left to hook the moose slows down noticeably. And if you do the same thing again, it happens again in the same place. If I remove the shader or the overlay everything goes smooth as silk again.

I really don’t think it’s due to lack of power on my computer. The configuration that I use in RetroArch is the one that comes by default.

I have tried with exclusive full screen, lowering the resolution, changing the swap chain value, enabling VSYNC and Triple Buffer in the NVIDIA control panel… everything I could find on the internet.

Please could you help me. Thanks a lot.


One thing to check in case there is integrated graphics is that retroarch is using the 4070 vs the integrated graphics.

In the Vulkan driver in the options you can actually choose which gpu is being used.

Also check your power settings to make sure your system isn’t throttling performance to reduce power, although crt-pi should take very little additional power…

I’m sure others will have suggestions as well :slight_smile:


It doesn’t work but thank you very much, I’ll keep looking for a solution. And by the way, the magnificent work you have done with Mega Bezel. I know quite a few people who will be eternally grateful to you.

1 Like

KF CPU should rule this out.

What model display are you using? Are you using FreeSync/VRR/GSync?

What type of CPU cooler do you have? Did you take the plastic off of the contact surface?

Maybe it’s a scheduling issue? RetroArch could be running on the “wrong” cores.

The problem as described is a bit vague so you might want to provide some more information in order to narrow things down a bit.

MSI AfterBurner and RivaTuner Statistics Server can provide valuable information for example CPU, GPU Temps and usage and clockspeeds.

1 Like

Hello, thanks for commenting.

I play on a 4K TV at 60hz. I don’t use GSync or FreeSync.

I use a liquid cooler and the contact surface is clean.

I have a Gigabyte motherboard and have tried with eCores enabled and disabled.

A year ago I was playing on a 1080p TV, with a Core i7 3700 and a GTX 1080 and the same thing happened to me.


I think this is just a refresh rate issue.

Go to “Settings >> Video” and make sure “Threaded Video” is disabled.

Then go to “Settings >> Video >> Output” and highlight “Estimated Screen Refresh Rate” …

…and press the “A” button on your controller. This will set both your screen refresh rate and your audio sync.

If you have never set an estimated screen refresh rate you may have to hold the button down to force it to take samples. (I forget.)


Thanks for the additional info. If this was happening over a year ago on vastly different but also capable hardware then maybe it’s a software/setup issue.

I hope you’re using Windows 11 with that processor. Have you tried a fresh install of RetroArch after backing up your existing folder of course?

If you can get those monitoring tools I mentioned setup that might help a great deal in eliminating some potential causes.

Also are you using the Vulkan video driver?

The more details about your setup the better.

Do you run background apps while playing? How much RAM and what type and speed do you have installed?

If you could have shared a video clip of the problem occurring while running RTSS monitoring that would be a great help as well.

1 Like

Hello good morning.

I am sending you some links to some photos with the video settings I use in RetroArch and a video playing SNES F-Zero with the Snes9x core.

At 8 seconds, when the blue ship jumps, the game slows down for the rest of the video (clearly seen in the ship’s thrusters).

As Cyber advises me, I have used RivaTurner to monitor it (it is the first time I have used it). I normally run RetroArch together with Launchbox but I’ve tried it standalone and it happens to me too.

I don’t have any apps running in the background except what runs Windows out of the box, and my rig has 32GB of DDR5 RAM and a WD Black SN850X 2TB NVMe.

I hope it helps you and thank you all very much.




try deleting the old retroarch.cfg and restart configuring. Might be useful to get a fresh start.

Do you have the correct resolution + refresh rate on the TV? What mode is the TV on? Do you have interpolation on the TV turned on? What about latency settings like run-ahead? Try disabling it for now.


Finally it has been solved!!

I always deactivate all filters and aids on television but following the advice of user c9f5fdda06 I have reviewed them and in the Game mode options I have found an option called Game Motion Plus activated. It has been turned off and everything is going smooth as silk.

Thank you all very much for the help you have given me. As a player since the days of the Spectrum 48k I thank you.

Seriously, with all my heart, thank you very much.


Thanks for the detailed response. I now have a much better understanding of the issue you’re experiencing.

First thing first, you have a smoking hot powerful GeForce RTX 4070Ti and you’re capturing video on a cellphone? Lol

You can use Shadow Play via GeForce Experience instead for a much better experience. It would also convey the smoothness of the actual experience better. You can press Alt-Z to bring up the Capture Menu. Alt-F9 starts and stops recording, Alt-F1 takes a screenshot. You can also take a screenshot in RetroArch by pressing F8 or going into the Quick Menu and choosing “Take Screenshot”.

Anyway in the GeForce Experience Shadow Play Capture Menu I set my bitrate to a custom setting of 95Mbps for my initial captures then transcode to H.265 using Handbrake, again using nVIDIA’s NVENC hardware video encoder using Encoder Preset - Slowest & Constant Quality 30 for near real-time transcoding on my old GeForce GTX 1070.

It’s good that you got RTSS setup and running as that’s an invaluable tool but you might need to adjust some of the monitoring settings in order to get the most out of it.

I’ll share a video or 2 showing what I mean.

What would be useful in this case are the framerate and frametime graphs as well as the GPU and CPU ClockSpeeds and overall load.

Another potentially gamechanging feature is the Frame Limiter. Without it, your GPU would be trying to generate as many frames as it can even though your display can only show a maximum of 60 every second so your GPU could actually be spinning its wheels generating a lot of discarded frames in cases where VSync is off or waiting a while to generate each frame and probably dropping to a low power state in between when VSync is On.

So I suggest you enable the RTSS Frame Limiter and set it to 60fps.

nVIDIA Control Panel also has a frame limiter which you can use instead but I prefer to use RTSS.

Also in nVIDIA Control Panel you should change your Power Management Mode to Prefer Maximum Performance. That will prevent your GPU ClockSpeed from fluctuating or dipping too low due to the very low load that RetroArch probably puts on it.

This can be done on a per app basis so you can change it for RetroArch alone.

Yes, you would also want your TV’s input to be operating in PC mode or Just Scan mode or whatever it’s equivalent.

You might also want to look into these settings, especially since you have so much excess computing “horsepower”.

In addition to that, you can also enable Frame Delay. You can start by leaving Auto Frame Delay Off then just increasing the Frame Delay until the game’s audio gets messed up then back it off to the setting before this happens. Then turn on Auto Frame Delay.

Be sure to save a Core or Game override after this.

1 Like

woo! Glad to hear it was something easy. Enjoy! :grin:

1 Like

I know I have no excuse.

RivaTurner, MSI Afterburner (the first time I heard it I thought it was Sega’s Arcade :sweat_smile:), Shadow Play is unknown to me, I’ve never used it.

Thank you very much for all your advice, everyone.

I’m glad to have met such beautiful people

1 Like

Seeing that you’re a bit new to these forums you might want to take a look at some of these projects:

1 Like

Thank you very much, I’ll take a look at them right away before I go to work.

1 Like