Sony Megatron Colour Video Monitor

The Sony Megatron Colour Video Monitor was the greatest CRT Sony never made.

Story

At the end of the 90’s in an underground R&D bunker located several kilometers below the Sony Tokyo HQ , Sony engineers were developing a revolutionary new screen for CRT’s that could morph its physical phosphors and thus simulate that of any screen on the market.

The Sony engineers code named it the ‘Megatron’.

Sadly it was so expensive it never made the light of day. Although the stuff of legends and myths over the proceeding decades, I am very proud and priviledged to bring you leaked video’s of the prototype display. I have also leaked the schematics encoded into a shader for you to experience in your very own home! I hope you enjoy the full glory of the Sony Megatron Colour Video Monitor.

Many Bothans died to bring us this information.

Sony Megatron Colour Video Monitor Prototype - Slot Mask Screen

Sony Megatron Colour Video Monitor Prototype - Aperture Grille Screen

Sony Megatron Colour Video Monitor Prototype - Shadow Mask Screen

Below are some close up comparison photo’s of the actual CRT’s (left) and the Sony Megatron simulations (right).

Sony PVM 2730QM

Sony PVM 20L4

Sammy Atomiswave Arcade

Bang & Olufsen MX8000

Viewsonic SuperClear A90f+

Virtua Fighter Arcade (Early)

To Download:

  • Get RetroArch 1.10+
  • Select D3D11, D3D12, Vulkan or GLCore Driver
  • Main Menu->Online Updater->Update Slang Shaders

You can find the shader that encodes the schematics here: Location: slang-shaders/hdr

These presets/shaders are intended to rely heavily on the quality of your display rather than the quality of your graphics card. As such you will need a bright display preferably DisplayHDR 600 but some SDR screens do get bright enough in particular laptop screens. A DisplayHDR 1000 display will really have the head room to cope with some of the hgher end PVM’s etc. This shader should run on a Pi4 and it will definitely run on integrated graphics.

Although previously I’ve said W-OLED’s aren’t supported I’ve seen new photographic evidence they are perfectly fine - possibly not quite as a good as IPS LCD’s in the highlights but its perfectly acceptable.

Please see instructions in RetroArch under ‘Quick Menu->Shaders->Shader Parameters’

ReShade Port

This CRT shader has also been ported to ReShade and a AutoHDR ReShade add-on has been added to support it both can be found here with instructions:

18 Likes

Merged!

I really wish I had an HDR pipeline to view it… but the off-axis bits, like luigi’s arm/glove and birdo’s arm highlights give an idea of how it “just works” without having to fake it.

3 Likes

Great stuff, thanks for merging @hunterk!

There’s various details that can be improved upon (there always is) but I think it’s an exciting new direction.

My phone is also changing the colours - in person it’s much closer colour wise to the PVM photo.

5 Likes

What’s really mindblowing is just how simple the shader is. There’s a couple of lines for the scalines, then a few for the HDR stuff, and the mask is like half of the code lol. Great stuff.

6 Likes

Yes that’s exactly what I was trying for: simplicity by relying on the hardware advances.

I’m sure we can complicate it with geometry warping and phosphor after glow (simulated via higher refresh rates) etc but this gets us a good proportion of the way.

5 Likes

That looks cool, I must get one of these toys.

1 Like

I’d love to see photos of anybody’s HDR display using this shader (or modification of it)

1 Like

Hi, Thanks for all of your efforts. The shader always fail to load for some reason ,

-I have HDR enabled from windows 10 side

-Video driver is set to DX12

-HDR is enabled from Retroarch

-HDR is enabled from the 4k TV side

What do you think is the issue?

Ahh yes you’ll need the latest nightly build of RetroArch. Which version are you running?

New photos:

Made the default setting the brighter and a little softer Sony PVM 2730 config as can be seen above.

Added two new configs crt-sony-pvm-20L4-4k-hdr.slangp and crt-sony-pvm-2730-4k-hdr.slangp for the Sony PVM 20L4 and 2730 respectively.

Updated the shader slightly to remove a few redundant shader parameters and exposed a sharpness parameter.

4 Likes

I may move these over to their own ‘HDR’ directory to avoid confusion, if that’s cool with you.

4 Likes

Yes thats absolutely fine with me - I wanted to do that in the first place but thought it a bit over stepping my mark.

Thanks!

4 Likes

I really like what you’re doing here.

I’m unable to test since I don’t have an HDR graphics card, but what mask are you using?

Mask 8 in guest dr venom will result in the most accurate-looking CRT phosphors @4K in a close-up photo. Looks like this:

Red, Yellow, Cyan, Blue

RxxRGxxGBxxB

TVL is 540 @ 4K, perfect for emulating a PVM. The black spaces between active subpixels get filled in by the natural bloom and it winds up looking like realistic RGB phosphors in a photo. Mask strength 100% is mandatory, of course.

1 Like

Hi, I can’t figure out why this shader isn’t working as intended for me. I enabled HDR in windows and have it disabled in Retroarch per your instructions (however this doesn’t seem to change anything; whether DX11 or DX12).

Here a couple of screenshots. Your HDR shader looks washed out on my LG C9 HDR Game mode.

The other shader is CRT-Geom-Deluxe which is notoriously low contrast – yet yours has less contrast for me. Thoughts?

Obviously impossible to convey HDR on SDR but I think the difference in contrast should be noticeable.

No sorry HDR should be enabled in RetroArch - it’s just the rest of the settings are disabled (or possibly better thought of as overridden) when this shader is enabled. Sorry for the confusion and do let me know how you get on.

You must also have the latest nightly build of RetroArch (in the last week or so)

1 Like

Thanks! Yes that’s exactly the pattern I plumped for as the default so we’re all in sync.

2 Likes

Just took a photo of what my shader looks like on my monitor with Super Mario Bros:

7 Likes

It doesn’t make a difference for me. Is it because I’m Windows 11? DX12, DX11 are also unreliable for me (nvidia).

So ignoring this shader for a moment when you go into RetroArch and turn on/off ‘Enable HDR’ do you see any difference in the menu - it should be a lot brighter with it enabled?

Yeah it’s brighter but your shader isn’t brighter. I’m familiar with what HDR looks like and the TV also tells me if it’s outputting HDR.

BTW I think I found the reason:

Microsoft Confirms Windows 11 Issue with HDR Displays (onmsft.com)