Lakka on Gigabyte Brix J4105 - Stuck at splash screen

Hello everyone,

I’m trying to install Lakka to my Gigabyte Brix BLCE-J4105. Everything installs, but the system never gets past the Lakka splash screen. I’ve looked all over for any info in regards to fixing this, and have done things such as disable secure boot, but no dice.

Any luck with others on getting this up and running?

You may try this documentation.

Also you can try to boot with live textmode ssh and provide some Lakka system and graphic card logs.

Thank you.

Did you get this working?

where can I find non efi build?

I am having the exact same issue. I can book via the live mode on my everyday PC. But the PC I want this installed on gets stuck at the splash screen. I have 2 of the exact same computers both do the same exact thing.

Trying to run this on an HP Compaq Pro 4300 Small Form Factor PC. Has the i3-3220 CPU in it. Using Lakka 3.5 64bit. I am thinking of trying the 32bit version but will lose 4GB of RAM then if that works. Also have not tried older version of Lakka yet. Was the next thing I am going to try. Anyone have any suggestions?

@Zeriu do you have this problem after installing Lakka, or when trying to install it?

It will be nice if you can provide some log as specified before, otherwise it will be difficult to help you.

Also check this thread if you are using Intel GPU (from gen4 to gen7 families) as some setup are required.

Thank you.

@Chaney I actually managed to fix it. I installed Lakka 3.4 and its working flawlessly. I have no idea what changes are in 3.5 but it will not boot regardless of what I tried on these older machines.

@Zeriu glad to hear you got it working. My next thing was going to recommend 3.4 rather than 3.5. I’ve been running Lakka on an Intel based MacMini for a while now and had issues with the 3.5 update until I found this thread: Generic PC 3.5 not working anymore with Intel GPU

If you try upgrading to 3.5, take a look at that first.