[SOLVED] Dolphin/GameCube — 2 players!

controller

#1

I bind my controllers successfully, and I played 2-players on SNES, just to test successfully. Everything is good for 2-players.
However, Dolphin/GameCube doesn’t allow Player 2 to move or click any buttons. Just a dead Player 2. I tried swapping controllers.
Has anyone had success with 2-player on Dolphin/GameCube?


Logitech F710 works w/ all cores except Nintendo Game Cube
#2

I don’t think so. They seem to be hooked up, but I haven’t seen any reports of successfully playing with more than one player.


#3

Thank you. I’m still looking at documentation on dolphin, and haven’t seen multiplayer referenced. Just didn’t know if I’m treading water, but I can wait for this to be implemented in the future.


#4

All you have to do is go to the Dolphin.ini in savefiles/Config/Dolphin/ and duplicate the first controller entry.
SIDevice0 = 6
SIDevice1 = 6


Lakka dolphin multiplayer
#5

oh wow, that’s good to know. Thanks for sharing your solution!


#6

You’re welcome. I don’t know what 6 means, but when in doubt, I duplicate the working variables.
I would assume a 5-Player would be all 6’s too. I think 6 might be the dev port or interrupt.


#7

Thanks! I was looking for this and everywhere i just found that it was impossible to play with 2 controllers on the dolphin core.


#8

I think many users would like to get this into a FAQs so it is never lost.


#9

I can’t seem to find the dolphin.ini file in the location mentioned here. I too am trying to get multiplayer going in gamecube. I am running lakka on a mac mini but basically a PC install of course. I have been searching via ssh to find dolphin.ini anywhere and have no luck.

Can anyone point me in the right direction please?


#10

You have to make it yourself. It doesn’t get created for you.


#11

Makes sense! Thank you very much! I’m new to Linux but am slowly figuring things out.


#12

Actually it is very easy to get the data files.

Go to Online Updater -> Content Downloader -> Dolphin -> dolphin-data.zip


#13

For me it was in the same directory as where I picked my ROMs from: ~/Download/User/Config/Dolphin.ini Setting SIDevice1 = 6 worked for me!


#14

Thank you for the note.


#15

After downloading the dolphin pack from the content downloader my file was located: storage/savefiles/User/Config

Hopefully this helps the next person. Seems like this should come with the ini having these changes done.


#16

Thank you for the note. I’m not sure why the location changed, I think I used a previous version and haven’t had to edit ever again.


#17

I’ve got this working for 2 Players.

Does anyone have a solution for 4 Players?


#18

I’m unable to test with 4 players.


#19

Any idea what I would need to test?


#20

could it be referencing a 6-axis controller ?