CyberLab Death To Pixels Shader Preset Packs

True. The Mega Bezel is the product of 3 years of work and contains thousands of lines of code. Not to mention over a hundred parameter settings. It can be daunting. The home thread is a good resource.

The cool thing is… no one here has a deadline… ask as many questions as you need.

As far as examples go I have 1800 presets that can be looked at in a text editor and browsed through live, like convenient window shopping.

That and regular support from the author of the shader, myself , @TheNamec, and Cyber, not to mention a very active community.

I think you might be happier with downloading the stand-alone Guest Advance shader.

While not every parameter Cyber is using is in the stand-alone, or has the same parameter name, simply using it and setting the RA aspect to 4x3, you might have an easier time.


Honestly it’d make more sense from a computer resource perspective to just run guests advanced by itself, in this specific use case. (As I don’t think any of HSM’s stuff is needed to accomplish that specific look.)


Take a read here if you would like to know how to disable the bezel/background graphics. You can read from this post and the next 2 or 3:

Another simple way to disable the bezel and backgrounds is to set Opacity to 0 for “Bezel General”, “Frame” and “Background” in the Shader Parameters.

Lastly, you can use the Zoom feature in the Shader Parameters and just Zoom the screen in until you crop out the entire bezel. Combined with lowering the Global Graphics Brightness to 0, that will give you full screen, correct aspect ratio, my shader presets and no Bezel nor Graphics.

Since you don’t care much for the bezel and reflections you should be using the presets in the MBZ__2__Performance_No_Reflections folder of my shader preset pack.

Also, if you’re using BSNES or Higan try setting your resolution to 512 x 224 for games like Super Mario World or Super Mario Kart. Or even better yet. Just use my CyberLab Composite - Pure PVM Edition shader preset for an even more authentic look!


Hi what you did certainly does work, and if you are happy with it that that’s totally cool.

If you want to try another solution, you may want to set your retroarch video aspect ratio to FULL, that’s because that’s why the sides are cut off/black.

Then if you want the screen bigger you can either use the shader parameters for viewport zoom, or Non-Integer scale.


If you want to use HSM and want a more zoomed-in look:

Retroarch Settings:
Settings > Video > Scaling > Integer Scale = Off
Settings > Video > Scaling > Integer Overscale = Off (up to your setup)
Settings > Video > Scaling > Aspect Ratio = Full

HSM Settings:
Int Scale Mode - Off | ShortAxies | BothAxes = 1
Int Scale Multiple Offset = 1

@Exception Just to expand on what @HyperspaceMadness said, I will list a simple and technically correct method to achieve what you’re looking for that shouldn’t create any other issues:

  1. Set Global Graphics Brightness to 0.

  2. Then under CRT Screen Scaling set Int. Scale Mode to 0 and Non-Integer Scale % to 100.

  3. Be sure to use the presets in the MBZ_2_Performance_No_Reflections folder.

This method using the Non-Integer Scale setting might be a bit more precise than using the Zoom and having to eyeball when you’ve reached the edges without going over. Since my presets use Integer Scale, you’d have to set that to mode 0 as stated in the steps above.


Hi Cyber,

I’m a retro gaming enthusiast since many years. Like many here, I grew up in the 80s/90s, played 8bit/16bit in real time, but since 2004 I’ve been playing purely on emulators (with original controllers).

The games didn’t look as great as I remembered them.

But I played them that way until a week ago where I stumbled upon your preset pack by accident, downloading it and the HSM shader.

I was absolutely speechless. I still can’t believe my eyes! It’s so nice to look at the games that way.

I have a few questions, if I may, after looking through the entire thread:

  1. When emulating NES/Famicom especially, I prefer a “curved” screen like in the old TVs. I noticed that your “TV” emulations are pretty “flat”. Is there a chance to see a preset with the curved glass TV of the 80s? Would be cool actually if all presets could be with “flat” or “curved” glasses…

  2. I noticed that you wrote that Composite - Sharp PVM Edition is your best preset. Is the RGB one the same, with a different color “gamut”? What’s the difference between them? Because the RGB one looks great on the SNES. Composite Sharp is a tad… darker?

  3. I took your advice to try Sega Genesis Sonic with the blending and transparency preset. It does look great. What does it do that makes it so different than the rest? I saw that you wrote: “Since you like playing Sonic in RGB mode, I’ll add an RGB version of my Blending and Transparency Edition preset so you’ll get proper waterfall and other transparency effects, even while enjoying the sharpness of RGB!” - I think this will be the best of both worlds? Do you recommend this preset for the Genesis or also for the SNES?

Thank you. I hope I wasn’t requesting in a harsh way. Nontheless, I appreciate what you already shared with the community, its golden!


I’ll have to answer you in parts with a few edits.

To raise the brightness, I suggest either increasing the Post CRT Brightness Setting which is near the top of the Shader Parameters List or changing the Scanline Type – gsl to a lower number. You shouldn’t need to touch anything else to get a great look that’s brighter.

Most of what you’ve read on Reddit over the past few months is probably already outdated.

The RGB Sharp currently in my Shader Preset Pack currently represents the “Old” look. It’s all a matter of personal preference any of them can be customized to get the type of look or to cater for different scenarios. I can’t recall saying that any particular one of my presets is the best. I might have had my favourites or ones that I used the most at the time.

It’s easy to get a curved “Screen” without curving the game. HSM Mega Bezel Reflection Shader supports independent curvature.

It’s just a few settings to adjust and I’d be happy to assist you in that regard. You can try to look for those options in the meantime and just save a Game or Core Preset when you have what you like.

The difference between Blending and Transparency and Composite - Sharp is that MDAPT is set to Mode 3, that’s all. It’s used for games like Sonic but can really mess up graphics and text in some games. So you have to see which games work best with which settings. Some look best with MDAPT off. Some look better with ScaleFX Off.

Composite - Pure is Composite - Sharp with both MDAPT and Scale FX disabled.

I have to run off now but feel free to follow up and explore the settings I’ve mentioned. I’m glad you like my presets! It feels good to know that I can share something that makes me excited and brings me joy with others. Be sure to share this with others that they too will also enjoy.

1 Like

Thank you.

I have your latest pack installed, however the MDAPT value in Composite Sharp PVM was 2. Does it make sense? because I read somewhere you wrote it should be 1 if its your latest pack.

It’s weird but the brightness post CRT you mentioned was ~320, even setting this at more than 400 I couldn’t get to the brightness of the RGB preset?

I see the curvature settings. There are quite a few there - is there any guide so I can see what’s the best practice for using it?


1 Like

The Post CRT Brightness is something to be a bit careful with because it directly multiplies the RGB value. So if you have something near white then you increase it it will clip. So if we are increasing it to 300% or 400% that makes me wonder if the original preset is quite dark for some reason. at 300% if your had a gradient which went from black to white then I think everything over the original 33% gray would be clipped to white

But if at the end of the day you like how it looks that’s totally fine.

1 Like

I don’t know when or where you read that but as I mentioned before:

What this means is that my presets are what I actually use in real life. They’re designed to suite my taste, viewing environment, lighting conditions and equipment setup primarily. These may vary considerably from user to user. While I welcome feedback, I also encourage customization in order to fine tune them to each individual’s liking and preference.

I gave you 2 options, use can use the second one instead or in addition to the first. I would suggest you not go overboard with the first. I’m very cautious and conservative when it comes to adjusting some of these settings so you might see me making small, incremental changes over a period of time.

I would have thought that you would have adjusted both to suit yourself and your situation. So you can try adjusting the Scanline Type – gsl first. There is no free lunch with these things, the darker the scanlines or stronger the mask strength the darker the preset overall all else being equal. You mess with the settings too much and you lose the look and benefits of that particular combination of settings. It’s a delicate balancing act.

Why are you even comparing the RGB-SHARP preset to any other preset in this respect? They are two completely different beasts. Use whichever one you prefer. In addition to that the RGB-SHARP preset is an older preset, development on my other newer presets continues on an ongoing basis. What you see today, may not remain the same next week or next 2 weeks especially when it comes to new presets or if I do an overhaul with significant changes.

As you can see in my presets I don’t use curvature so by that nature I really wouldn’t be the best person to advise you much here other than to take your time and experiment. Change a setting and you will see an effect. If you like what you see, keep it, if you don’t change it back or adjust it the other way. That’s how all of these presets were born and created.

Most of the time when I’m responding to posts I’m not in front of my computer so I won’t have all of the Shader Parameters in front of me.

Leave the Post CRT Brightness Setting alone and prioritize the Scanline Type – gsl setting if you wish to make things brighter. You can slightly tweak the Post CRT Brightness Setting afterwards if you wish but I don’t recommend going over 212 at first but you can feel free to go as high as you need.

Here’s a third option. I don’t know if you’re using a 4K screen but you can try my 1080p Optimized Presets as well even if you’re using a 4K screen.

You’re also free to and encouraged to adjust the MDAPT and Scale FX settings to suit your tastes and whatever particular game you’re playing. Just save a Game, Core, Content Directory or even a new Preset when you’re finished adjusting things to your liking. Be sure to turn on Use Simple Presets first.

You can let me know if you need further assistance.

Hope you can get to spend more time enjoying some games as opposed to tinkering because that’s the real reason for of all of this - To relax, have fun and enjoy!


Hi, I was wondering if you still had that grungy late 70s early 80s RF style preset still kicking around. Occasionally I want to relive my childhood of an nes/snes with crappy rf connection on an old tv


You mean these?

These may not work properly with the current HSM Mega Bezel Reflection Shader but you can open up almost any of my current presets and manually add these settings until you get what you’re looking for. You can try it directly on an existing preset file or better yet, within the game in the Shader Parameters Menu. My RGB-Sharp PVM Edition preset is closest to my older presets that these Old TV Shaders were originally based on but I’m sure you can also get great or even better results using the more up to date PVM Edition presets in the package.

Alternatively, you can take any of my new presets, then head to the GTU Section and press the Start button or Enter Key on each of the Settings in that section. That alone should give you a nice soft, smeary looking foundation.

You can make the image even worse by heading down to GDV Section and doing the same to the Horizontal Sharpness as well as the setting directly below it. Followed by adding a little Noise in the final section of the Parameters. The last thing you might want to do is increase the Halation a little bit or a lot bit and you might even want to add either Guest’s or HSM’s rolling scanlines to finish the whole mess! Lol

I’d love to see what you come up with so feel free to share your settings and screenshots!


Hi HyperspaceMadness,

Thank you for helping out. :slight_smile:

I have tried 3 different solutions now, and they all seems to be fine. :+1:

Can someone tell me the technical difference between the solutions posted here?

Solution 1: Viewport zoom

Solution 2:

  • Retroarch Settings:

  • Settings > Video > Scaling > Integer Scale = Off

  • Settings > Video > Scaling > Integer Overscale = Off (up to your setup)

  • Settings > Video > Scaling > Aspect Ratio = Full

  • HSM Settings:


  • Int Scale Mode - Off | ShortAxies | BothAxes = 1

  • Int Scale Multiple Offset = 1

Solution 3.

  1. Set Global Graphics Brightness to 0.
  2. Then under CRT Screen Scaling set Int. Scale Mode to 0 and Non-Integer Scale % to 100.
  3. Be sure to use the presets in the MBZ_2_Performance_No_Reflections folder.

I can see that Cyber mentions that the 3’rd option might be more correct. Does that mean that even without integer scaling, the picture will still show proper aspect ratio, and scanlines etc.? Cyber why do I have to use the non-reflection shader to use this trick, just curious

BTW: Thank you very much also c9f5fdda06 and Cyber for helping out.


I would say that the most straight forward thing is to:

  1. Use the standard HSM setup instructions which includes
    • Settings > Video > Scaling > Aspect Ratio = Full
    • Settings > Video > Scaling > Integer Scale = Off
    • This will get the shader to use the entire Retroarch window, this is normally what you want with the Mega Bezel because the sides are filled with graphics
  2. Set shader parameters:
    • Global Graphics Brightness = 0
    • Int. Scale Mode = 0
    • Non-Integer Scale % to 100.

This will result in having some reflections on the left and right of the screen and your screen will take up the full height.

I think this was suggested because if you were not wanting the reflections --because they were offscreen-- then the no reflection uses less GPU cycles

1 Like

Thanks for the explanation. :slight_smile:

Everything is set up very nice now, except vertical games like 1941, and 19xx etc. Scanlines and aspect ratio is completely destroyed. I have tried changing a few settings which sounded like they might have something to do with the vertical aspect, but to no avail.

What need I change to make vertical games appear as good as the normal (horizontal) ones?

Correct picture (horizontal game)

Wrong picture (vertical game)

1 Like

Lookin good!

Take a look at the setup instructions, I just updated them recently, you need to turn on advanced options ui and turn off the allow core rotation, then do rotation inside the shader parameters with rotate crt.

I am working on a slightly longer term fix to this which should hopefully rotate automatically, but you will still have to turn off the allow core rotation.


I have tried the recommendations in the topic you are linking to. When you do this the screen orientation is correct, and it seems the aspect ratio is also maintained. But there is a problem with the colors/saturation/brightness. My guess is that it may have something to do with the bezel/frame and the shading of those, which seem to reflect differently on a vertical game. Especially on the right side of the gameplay area.

This is at least evident on Cyber’s “arcade sharp 1440p PVM Edition” shader.

It may be difficult to see from a phone capture…

Notice especially the right side of the screen. The colors are oversaturated, and the brightness is too high.

ADDED: I have found that if I change the “Int Scale Multiple Offset” it has an effect on the colors. Normal setting (0) produces the strange saturation, but increasing it to 1 normalises the colors, but on the other hand makes the image overlap the screen.

1 Like

Are you having this same issue with the presets in the performance folder?

You can also try some of my presets in the 1080p Optimized Folder and see if it’s still happening.

Yes. For some (not all) shaders, it seems to be affected by “Int Scale Mode”. When I enable “Int Scale Mode” on your shaders, Cyber, it always produces the strange saturation effect. The same happens with some of the presets from the Mega Bezel pack, while others behave as they should. Why they differentiate, I have no idea.

On DoDonPachi it is VERY evident.

1 Like